10 novembro 2009

Problemas na atualização para o Kubuntu 9.10

Atualizei o computador de minha casa com o Kubuntu 9.10 e vou postar minhas impressões sobre alguns pontos dessa nova versão e relatar alguns problemas que tive e que mais pessoas podem ter.


Como instalar o sistema do zero é algo muito trabalhoso, demorado, tem que se configurar tudo novamente, optei por fazer a atualização automática do sistema, mais prática e rápida... pelo menos era assim que eu pensava. Bom, já esperava uma demora para baixar as centenas de megabytes necessários, e depois de algumas horas de download finalmente o sistema começou a ser atualizado de fato, e alguns minutos depois, e somente um questionamento se eu queria ou não manter o antigo arquivo de configuração do MySQL e o aviso de que a versão instalada do gcc não era compatível com a nova versão do sistema, o sistema de atualização automática terminou o seu trabalho sem nenhum problema, ou quase nenhum. No geral o processo de atualização é fácil e rápido, sistema muito bem desenvolvido.

Após reiniciar o computador notei dois grandes problemas: o som estava mudo e a interface gráfica apresentava inconsistência, chegando a deixar a tela toda preta, algumas vezes nem mostrava a tela de login. Sobre o som eu procurei alguma solução na internet, mas como não tive sucesso com as dicas resolvi partir para resolução do problema de vídeo.

Tentei reinstalar o driver da nvidia, porém quando o sistema tentou compilar o módulo pro kernel atual deu uma mensagem de erro dizendo que a versão do compilador era incompatível com a versão do kernel atual. Achei muito estranho a mensagem e fui conferir a versão do kernel q estava rodando, e era a versão 2.6.28, porém a versão do kernel instalada no Kubuntu 9.10 é a 2.6.31. Foi ai que percebi que o grub não havia sido atualizado para dar boot pela versão mais nova do kernel, tarefa que era para ser realizada automaticamente pelo sistema de atualização. Bom, eu atualizei o arquivo \boot\grub\menu.lst adicionando uma entrada para o novo kernel e reiniciei o sistema. Antes de acessar o KDE eu reinstalei o driver da nvidia, dessa vez sem erro nenhum, depois voltei para a interface gráfica e fiz login no KDE... E olha só, todos os problemas resolvidos. Não sei se o que ocorreu comigo ocorreu com mais alguém exatamente da mesma forma, mas fica a dica para quem tiver um problema parecido.

Fora esse contratempo o sistema está ótimo. O visual mudou, saiu de um tema escuro para um tema mais claro, bem agradável. Mas o que me impressionou mesmo foi o tempo de inicialização do sistema. Em meu modesto computador (Athlon 64 de 2 GHz e 1 GB de RAM, quase quatro anos de uso) antes da atualização levava mais de um minuto desde o grub até a tela de login, agora o sistema inicializa num tempo entre 40 e 45 segundos!! Uma melhoria bem notável. Não utilizei muito o sistema desde a atualização, porém tive uma leve impressão que o sistema como um todo está mais rápido. Outro ponto interessante desta versão é a integração como o serviço Ubuntu One, que é um sistema de armazenamento de arquivos na internet (falarei mais dele num próximo post).